<!DOCTYPE html>
<html>
<head>

    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />

    <title>This week in Mixed Reality: Issue 8</title>
    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="stylesheet" type="text/css" href="/assets/built/screen.css?v=1eb6f5ce17" />

    <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
    <link rel="canonical" href="https://blog.mozvr.com/this-week-in-mixed-reality-issue-8/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    
    <meta property="og:site_name" content="Mozilla Mixed Reality Blog" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="This week in Mixed Reality: Issue 8" />
    <meta property="og:description" content="Now that we are back from our Chicago work week, we are heads down adding new features, making improvements and fixing bugs. Browsers We are focusing on making general improvements and on the Widgets API across the Android platforms: Improved the widgets API to create all the windows, widgets and" />
    <meta property="og:url" content="https://blog.mozvr.com/this-week-in-mixed-reality-issue-8/" />
    <meta property="og:image" content="https://blog.mozvr.com/content/images/2018/06/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" />
    <meta property="article:published_time" content="2018-06-01T15:45:32.000Z" />
    <meta property="article:modified_time" content="2018-06-01T15:45:32.000Z" />
    <meta property="article:tag" content="Updates" />
    
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="This week in Mixed Reality: Issue 8" />
    <meta name="twitter:description" content="Now that we are back from our Chicago work week, we are heads down adding new features, making improvements and fixing bugs. Browsers We are focusing on making general improvements and on the Widgets API across the Android platforms: Improved the widgets API to create all the windows, widgets and" />
    <meta name="twitter:url" content="https://blog.mozvr.com/this-week-in-mixed-reality-issue-8/" />
    <meta name="twitter:image" content="https://blog.mozvr.com/content/images/2018/06/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Nancy Hang" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="Updates" />
    <meta name="twitter:site" content="@mozillareality" />
    <meta property="og:image:width" content="1400" />
    <meta property="og:image:height" content="770" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "Mozilla Mixed Reality Blog",
        "logo": "https://blog.mozvr.com/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png"
    },
    "author": {
        "@type": "Person",
        "name": "Nancy Hang",
        "image": {
            "@type": "ImageObject",
            "url": "https://blog.mozvr.com/content/images/2018/03/08_Nancy.png",
            "width": 1008,
            "height": 1008
        },
        "url": "https://blog.mozvr.com/author/nancy/",
        "sameAs": []
    },
    "headline": "This week in Mixed Reality: Issue 8",
    "url": "https://blog.mozvr.com/this-week-in-mixed-reality-issue-8/",
    "datePublished": "2018-06-01T15:45:32.000Z",
    "dateModified": "2018-06-01T15:45:32.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://blog.mozvr.com/content/images/2018/06/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png",
        "width": 1400,
        "height": 770
    },
    "keywords": "Updates",
    "description": "Now that we are back from our Chicago work week, we are heads down adding new features, making improvements and fixing bugs. Browsers We are focusing on making general improvements and on the Widgets API across the Android platforms: Improved the widgets API to create all the windows, widgets and",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://blog.mozvr.com/"
    }
}
    </script>

    <script src="/public/ghost-sdk.min.js?v=1eb6f5ce17"></script>
<script>
ghost.init({
	clientId: "ghost-frontend",
	clientSecret: "e2b06445780a"
});
</script>
    <meta name="generator" content="Ghost 1.23" />
    <link rel="alternate" type="application/rss+xml" title="Mozilla Mixed Reality Blog" href="https://blog.mozvr.com/rss/" />
    <style>
  /* https://blog.mozvr.com/webvr-api-transitions-to-w3c-standard/ */
  .post-card-image[style*="w3c_home"] {
    background-color: #fff;
    background-size: 200px auto;
  }
  .post-full-image[src*="w3c_home"] {
    background-color: #fff;
    height: 18rem;
    object-fit: contain;
  }

  /* https://blog.mozvr.com/firefox-reality-bringing-the-immersive-web-to-mixed-reality-headsets/ */
  .post-card-image[style*="Wordmark"] {
    background-color: #b8cfff;  /* Colour lightened from background colour used in masthead here: https://blog.mozilla.org/blog/2018/04/03/mozilla-brings-firefox-augmented-virtual-reality/ */
    background-size: 90% auto;
  }
  .post-full-image[src*="Wordmark"] {
    height: 14rem;
    object-fit: contain;
  }

  .post-card-excerpt p:after {
    content: "\00a0…";
    opacity: .5;
  }
    
  .post-full-content img,
  .post-full-content video {
    max-width: 840px;
  }

  .post-full-content h2 {
    margin-bottom: .75rem;
  }
</style>
<link async rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.css">

</head>
<body class="post-template tag-updates">

    <div class="site-wrapper">

        

<header class="site-header outer">
    <div class="inner">
        <nav class="site-nav">
  <div class="site-nav-left">
    <a href="https://blog.mozvr.com">
      <img class="site-nav__logo" src="/assets/img/mrb-logo.svg?v=1eb6f5ce17" />
    </a>
  </div>
  <div class="site-nav-right">
     <ul class="nav" role="menu">
    <li class="nav-blog" role="menuitem"><a href="https://blog.mozvr.com/">Blog</a></li>
    <li class="nav-mozilla-reality" role="menuitem"><a href="https://mixedreality.mozilla.org">Mozilla Reality</a></li>
    <li class="nav-aframe" role="menuitem"><a href="https://aframe.io/">A-Frame</a></li>
</ul>
 
  </div>
</nav>
    </div>
</header>


<main id="site-main" class="site-main outer" role="main">
    <div class="inner">

        <article class="post-full post tag-updates ">

            <img class="post-full-image" src="/content/images/2018/06/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" alt="featured image" />


            <header class="post-full-header">
                    <a href="/tag/updates/"><span class="post-primary-tag">Updates</span></a>
                <h1 class="post-full-title">This week in Mixed Reality: Issue 8</h1>
                <section class="post-full-meta">
                        <img class="post-meta-author-image" src="/content/images/2018/03/08_Nancy.png" alt="Nancy Hang" />
                    <span class="post-meta-author"><a href="/author/nancy/">Nancy Hang</a></span>
                    <span>&nbsp;-&nbsp;</span>
                    <time class="post-full-meta-date" datetime="2018-06-01">1 June 2018</time>
                </section>
            </header>
            <section class="post-full-content">
                <div class="kg-card-markdown"><p>Now that we are back from our Chicago work week, we are heads down adding new features, making improvements and fixing bugs.</p>
<h1 id="browsers">Browsers</h1>
<p>We are focusing on making general improvements and on the Widgets API across the Android platforms:</p>
<ul>
<li>
<p>Improved the widgets API to create all the windows, widgets and placements from Java:</p>
<ul>
<li>Create &amp; place all widgets from Java</li>
<li>Generate ids from Java in order to avoid having to wait the callback  with the C++ handler</li>
<li>Remove the widget creation enumerations</li>
<li>Consider moving visibility to WidgetPlacement class</li>
<li>Adapt all widget children to the new API</li>
</ul>
</li>
<li>
<p>Resolved startup issues in GeckoView fixing, the initial home page experience</p>
</li>
</ul>
<h1 id="social">Social</h1>
<p>This week we spent time prioritizing features and planning for the rest of the year for the Hubs by Mozilla product:</p>
<ul>
<li>Added documentation of Hubs A-Frame components in the code and <a href="http://github.com/mozilla/hubs/blob/master/doc/index.md">here</a></li>
<li>Proof of concept of scrollable list view with react-surface, which will allow full flexbox layout + react enabled UI drawn to webgl canvas in VR</li>
<li>Concluded planning and requirements doc for environment building kit, editor work kicked off this week</li>
</ul>
<p>Join our public <a href="https://webvr.rocks/slack">WebVR Slack</a> <a href="https://webvr.slack.com/messages/social">#social channel</a> to participate in on the discussion!</p>
<h1 id="contentecosystem">Content ecosystem</h1>
<p>We are continuing to fix bugs found on the Unity WebVR exporter tool.</p>
<p>Found a critical bug? File it in our public GitHub repo or let us know on the public <a href="https://webvr.rocks/slack">WebVR Slack</a> <a href="https://webvr.slack.com/messages/unity">#unity channel</a> and as always, join us in our discussion!</p>
<p>Stand by for new features and improvements across our three areas next week!</p>
</div>
            </section>

            <section class="subscribe-form">
                <h3 class="subscribe-form-title">Subscribe to Mozilla Mixed Reality Blog</h3>
                <p>Get the latest posts delivered right to your inbox</p>
                <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    <script>(function(g,h,o,s,t){h[o]('.location')[s]=h[o]('.location')[s] || g.location.href;h[o]('.referrer')[s]=h[o]('.referrer')[s] || h.referrer;})(window,document,'querySelector','value');</script>
</form>


            </section>

            <footer class="post-full-footer">

                <section class="author-card">
                        <img class="author-profile-image" src="/content/images/2018/03/08_Nancy.png" alt="Nancy Hang" />
                    <section class="author-card-content">
                        <h4 class="author-card-name"><a href="/author/nancy/">Nancy Hang</a></h4>
                            <p>Senior Engineering Program Manager, Mixed Reality.</p>
                    </section>
                </section>
                <div class="post-full-footer-right">
                    <a class="author-card-button" href="/author/nancy/">Read More</a>
                </div>

            </footer>


        </article>

    </div>
</main>

<aside class="read-next outer">
    <div class="inner">
        <div class="read-next-feed">
                <article class="read-next-card"

                >
                    <header class="read-next-card-header">
                        <small class="read-next-card-header-sitetitle">&mdash; Mozilla Mixed Reality Blog &mdash;</small>
                        <h3 class="read-next-card-header-title"><a href="/tag/updates/">Updates</a></h3>
                    </header>
                    <div class="read-next-divider"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M13 14.5s2 3 5 3 5.5-2.463 5.5-5.5S21 6.5 18 6.5c-5 0-7 11-12 11C2.962 17.5.5 15.037.5 12S3 6.5 6 6.5s4.5 3.5 4.5 3.5"/></svg>
</div>
                    <div class="read-next-card-content">
                        <ul>
                            <li><a href="/this-week-in-mixed-reality-7/">This week in Mixed Reality: Issue 7</a></li>
                            <li><a href="/this-week-in-mixed-reality-issue-6/">This week in Mixed Reality: Issue 6</a></li>
                            <li><a href="/this-week-in-mixed-reality-issue-5/">This week in Mixed Reality: Issue 5</a></li>
                        </ul>
                    </div>
                    <footer class="read-next-card-footer">
                        <a href="/tag/updates/">See all 7 posts →</a>
                    </footer>
                </article>


                <article class="post-card post tag-updates">
        <a class="post-card-image-link" href="/this-week-in-mixed-reality-7/">
            <div class="post-card-image" style="background-image: url(/content/images/2018/05/MR.png)"></div>
        </a>
    <div class="post-card-content">
        <a class="post-card-content-link" href="/this-week-in-mixed-reality-7/">
            <header class="post-card-header">
                    <span class="post-card-tags">Updates</span>
                <h2 class="post-card-title">This week in Mixed Reality: Issue 7</h2>
            </header>
            <section class="post-card-excerpt">
                <p>Missed us last week? Our team met in Chicago for a work week. If you had the chance to come and meet us at the CHIVR / AR Chicago meetup, thanks for swinging by.</p>
            </section>
        </a>
        <footer class="post-card-meta">
                <img class="author-profile-image" src="/content/images/2018/03/08_Nancy.png" alt="Nancy Hang" />
            <span class="post-card-author"><a href="/author/nancy/">Nancy Hang</a></span>
        </footer>
    </div>
</article>

        </div>
    </div>
</aside>

<div class="floating-header">
    <div class="floating-header-logo">
        <a href="https://blog.mozvr.com">
            <span>Mozilla Mixed Reality Blog</span>
        </a>
    </div>
    <span class="floating-header-divider">&mdash;</span>
    <div class="floating-header-title">This week in Mixed Reality: Issue 8</div>
    <div class="floating-header-share">
        <div class="floating-header-share-label">Share this <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24">
    <path d="M7.5 15.5V4a1.5 1.5 0 1 1 3 0v4.5h2a1 1 0 0 1 1 1h2a1 1 0 0 1 1 1H18a1.5 1.5 0 0 1 1.5 1.5v3.099c0 .929-.13 1.854-.385 2.748L17.5 23.5h-9c-1.5-2-5.417-8.673-5.417-8.673a1.2 1.2 0 0 1 1.76-1.605L7.5 15.5zm6-6v2m-3-3.5v3.5m6-1v2"/>
</svg>
</div>
        <a class="floating-header-share-tw" href="https://twitter.com/share?text=This%20week%20in%20Mixed%20Reality%3A%20Issue%208&amp;url=https://blog.mozvr.com/this-week-in-mixed-reality-issue-8/"
            onclick="window.open(this.href, 'share-twitter', 'width=550,height=235');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M30.063 7.313c-.813 1.125-1.75 2.125-2.875 2.938v.75c0 1.563-.188 3.125-.688 4.625a15.088 15.088 0 0 1-2.063 4.438c-.875 1.438-2 2.688-3.25 3.813a15.015 15.015 0 0 1-4.625 2.563c-1.813.688-3.75 1-5.75 1-3.25 0-6.188-.875-8.875-2.625.438.063.875.125 1.375.125 2.688 0 5.063-.875 7.188-2.5-1.25 0-2.375-.375-3.375-1.125s-1.688-1.688-2.063-2.875c.438.063.813.125 1.125.125.5 0 1-.063 1.5-.25-1.313-.25-2.438-.938-3.313-1.938a5.673 5.673 0 0 1-1.313-3.688v-.063c.813.438 1.688.688 2.625.688a5.228 5.228 0 0 1-1.875-2c-.5-.875-.688-1.813-.688-2.75 0-1.063.25-2.063.75-2.938 1.438 1.75 3.188 3.188 5.25 4.25s4.313 1.688 6.688 1.813a5.579 5.579 0 0 1 1.5-5.438c1.125-1.125 2.5-1.688 4.125-1.688s3.063.625 4.188 1.813a11.48 11.48 0 0 0 3.688-1.375c-.438 1.375-1.313 2.438-2.563 3.188 1.125-.125 2.188-.438 3.313-.875z"/></svg>
        </a>
        <a class="floating-header-share-fb" href="https://www.facebook.com/sharer/sharer.php?u=https://blog.mozvr.com/this-week-in-mixed-reality-issue-8/"
            onclick="window.open(this.href, 'share-facebook','width=580,height=296');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M19 6h5V0h-5c-3.86 0-7 3.14-7 7v3H8v6h4v16h6V16h5l1-6h-6V7c0-.542.458-1 1-1z"/></svg>
        </a>
    </div>
    <progress class="progress" value="0">
        <div class="progress-container">
            <span class="progress-bar"></span>
        </div>
    </progress>
</div>




         <footer class="footer">
  <div class="footer__inner">

    <div>
      <a href="http://mozilla.org">
        <img class="footer__logo" src="/assets/img/moz-logo.svg?v=1eb6f5ce17" />
      </a>
    </div>
    <div>
      <span class="footer__title">Additional Links</span>
      <ul class="footer__list">
        <li>
          <a href="https://vr.mozilla.org">Mozilla Mixed Reality</a>
        </li>
        <li>
          <a href="https://aframe.io/">A-Frame</a>
        </li>
        <li>
          <a href="https://aframe.io/blog/">A-Frame Blog</a>
        </li>
        <li>
          <a href="https://twitter.com/mozillareality">Twitter</a>
        </li>
        <li>
          <a href="https://github.com/mozillareality">GitHub</a>
        </li>
      </ul>
    </div>
    <div>
      <span class="footer__title">Mozilla</span>
      <ul class="footer__list">
        <li>
          <a href="https://www.mozilla.org/about/">About</a>
        </li>
        <li>
          <a href="https://www.mozilla.org/contact/">Contact Us</a>
        </li>
        <li>
          <a href="https://donate.mozilla.org/en-US/?presets=100,50,25,15&amp;amount=50&amp;utm_source=mozilla.org&amp;utm_medium=referral&amp;utm_content=footer&amp;currency=usd">Donate</a>
        </li>
      </ul>
    </div>
  </div>
  <div class="footer__legal">
    <ul class="footer__legal-list">
      <li>
        <a href="https://www.mozilla.org/privacy/">Privacy</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/privacy/websites/#cookies">Cookies</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/about/legal/">Legal</a>
      </li>
    </ul>
  </div>
</footer>

    </div>

    <div id="subscribe" class="subscribe-overlay">
        <a class="subscribe-overlay-close" href="#"></a>
        <div class="subscribe-overlay-content">
                <img class="subscribe-overlay-logo" src="/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" alt="Mozilla Mixed Reality Blog" />
            <h1 class="subscribe-overlay-title">Subscribe to Mozilla Mixed Reality Blog</h1>
            <p class="subscribe-overlay-description">Stay up to date! Get all the latest &amp; greatest posts delivered straight to your inbox</p>
            <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    <script>(function(g,h,o,s,t){h[o]('.location')[s]=h[o]('.location')[s] || g.location.href;h[o]('.referrer')[s]=h[o]('.referrer')[s] || h.referrer;})(window,document,'querySelector','value');</script>
</form>


        </div>
    </div>

    <script
        src="https://code.jquery.com/jquery-3.2.1.min.js"
        integrity="sha256-hwg4gsxgFZhOsEEamdOYGBf13FyQuiTwlAQgxVSNgt4="
        crossorigin="anonymous">
    </script>
    <script type="text/javascript" src="/assets/js/jquery.fitvids.js?v=1eb6f5ce17"></script>


    <script>

// NOTE: Scroll performance is poor in Safari
// - this appears to be due to the events firing much more slowly in Safari.
//   Dropping the scroll event and using only a raf loop results in smoother
//   scrolling but continuous processing even when not scrolling
$(document).ready(function () {
    // Start fitVids
    var $postContent = $(".post-full-content");
    $postContent.fitVids();
    // End fitVids

    var progressBar = document.querySelector('progress');
    var header = document.querySelector('.floating-header');
    var title = document.querySelector('.post-full-title');

    var lastScrollY = window.scrollY;
    var lastWindowHeight = window.innerHeight;
    var lastDocumentHeight = $(document).height();
    var ticking = false;

    function onScroll() {
        lastScrollY = window.scrollY;
        requestTick();
    }

    function onResize() {
        lastWindowHeight = window.innerHeight;
        lastDocumentHeight = $(document).height();
        requestTick();
    }

    function requestTick() {
        if (!ticking) {
            requestAnimationFrame(update);
        }
        ticking = true;
    }

    function update() {
        var trigger = title.getBoundingClientRect().top + window.scrollY;
        var triggerOffset = title.offsetHeight + 35;
        var progressMax = lastDocumentHeight - lastWindowHeight;

        // show/hide floating header
        if (lastScrollY >= trigger + triggerOffset) {
            header.classList.add('floating-active');
        } else {
            header.classList.remove('floating-active');
        }

        progressBar.setAttribute('max', progressMax);
        progressBar.setAttribute('value', lastScrollY);

        ticking = false;
    }

    window.addEventListener('scroll', onScroll, {passive: true});
    window.addEventListener('resize', onResize, false);

    update();
});
</script>


    <script src="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.js"></script>
<script>
(function () {
  /* global ga, performance */
  // Toggle this variable to output to the console debug GA messages.
  var debug = false;
  function initGoogleAnalytics (id, opts) {
    (function (c, v, a, n) {
      c.GoogleAnalyticsObject = n;

      c[n] = c[n] || function () {
        (c[n].q = c[n].q || []).push(arguments);
      };
      c[n].l = 1 * new Date();

      var s = v.createElement('script');
      s.async = true;
      s.src = a;
      s.addEventListener('load', enableDebug);

      var m = v.getElementsByTagName('script')[0];
      m.parentNode.insertBefore(s, m);
    })(window, document, 'https://www.google-analytics.com/analytics.js', 'ga');

    function enableDebug () {
      if (!debug) {
        return;
      }
      window.ga = ga = console.info.bind(console);
    }

    enableDebug();

    ga('create', id, opts);
    ga('set', 'forceSSL', true);
    ga('send', 'pageview');
  }

  function initGoogleAnalyticsEvents () {
    window.addEventListener('load', function () {
      setTimeout(function () {
        var t = performance.timing;
        // Credit to https://github.com/addyosmani/timing.js/blob/c58c164/timing.js#L67-L88:
        // Total time from start to load.
        gaSendPageTiming('loadTime', t.loadEventEnd - t.fetchStart);
        // Time spent constructing the DOM tree.
        gaSendPageTiming('domReadyTime', t.domComplete - t.domInteractive);
        // Time consumed preparing the new page.
        gaSendPageTiming('readyStart', t.fetchStart - t.navigationStart);
        // Time spent during redirection.
        gaSendPageTiming('redirectTime', t.redirectEnd - t.redirectStart);
        // AppCache.
        gaSendPageTiming('appcacheTime', t.domainLookupStart - t.fetchStart);
        // Time spent unloading documents.
        gaSendPageTiming('unloadEventTime', t.unloadEventEnd - t.unloadEventStart);
        // DNS query time.
        gaSendPageTiming('lookupDomainTime', t.domainLookupEnd - t.domainLookupStart);
        // TCP connection time.
        gaSendPageTiming('connectTime', t.connectEnd - t.connectStart);
        // Time spent during the request.
        gaSendPageTiming('requestTime', t.responseEnd - t.requestStart);
        // Request to completion of the DOM loading.
        gaSendPageTiming('initDomTreeTime', t.domInteractive - t.responseEnd);
        // Load event time.
        gaSendPageTiming('loadEventTime', t.loadEventEnd - t.loadEventStart);
      });
    });

    var gaSendTiming = function (timingCategory, timingLabel) {
      return function (timingVar, timeEnd) {
        if (typeof timeEnd === 'undefined') {
          timeEnd = performance.now();
        }
        ga('send', {
          hitType: 'timing',
          timingCategory: timingCategory,
          timingVar: timingVar,
          timingValue: timeEnd,
          timingLabel: timingLabel
        });
      };
    };

    var gaSendPageTiming = gaSendTiming('page');

    ga('send', 'event', 'pageload.title', document.title);
    ga('send', 'event', 'pageload.location', window.location.href);
    ga('send', 'event', 'pageload.pathname', window.location.pathname);
    ga('send', 'event', 'pageload.querystring', window.location.search);
    ga('send', 'event', 'pageload.hash', window.location.hash);

    // NOTE: These lines are commented out because Steam VR / Oculus would open on desktop.
    //ga('send', 'event', 'supports.getVRDisplays', 'getVRDisplays' in navigator);
    //ga('send', 'event', 'supports.getVRDevices', 'getVRDevices' in navigator);

    function handleOutboundLinkClicks (evt) {
      ga('send', 'event', {
        eventCategory: 'Outbound Link',
        eventAction: 'click',
        eventLabel: evt.target.href,
        transport: 'beacon'
      });
    }

    window.addEventListener('click', function (evt) {
      var el = evt.target.closest && evt.target.closest('a[href], input[type=button], button, img, picture');
      if (!el) { return; }
      //var txt = getElText(el);
      //if (!txt) { return; }
      handleOutboundLinkClicks(evt);
    });
  }

  function getElText (el) {
    var txt = el.textContent.trim();
    if (txt) {
      return txt;
    }
    var img = el.tagName === 'IMG' ? el : el.querySelector('img');
    if (img) {
      return img.getAttribute('alt') || img.getAttribute('title');
    }
    return '';
  }
  initGoogleAnalytics('UA-77033033-11', {alwaysSendReferrer: true});
  initGoogleAnalyticsEvents();
})();
</script>

</body>
</html>
