<!DOCTYPE html>
<html>
<head>

    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />

    <title>Semantic Placement in Augmented Reality using MrEd</title>
    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="stylesheet" type="text/css" href="/assets/built/screen.css?v=e53b21d552" />

    <meta name="description" content="Semantic Placement in Augmented Reality using MrEd" />
    <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
    <link rel="canonical" href="https://blog.mozvr.com/semantic-placement-in-ar/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    
    <meta property="og:site_name" content="Mozilla Mixed Reality Blog" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Semantic Placement in Augmented Reality using MrEd" />
    <meta property="og:description" content="In this article we’re going to take a brief look at how we may want to think about placement of objects in Augmented Reality.
" />
    <meta property="og:url" content="https://blog.mozvr.com/semantic-placement-in-ar/" />
    <meta property="og:image" content="https://blog.mozvr.com/content/images/2019/09/Screen-Shot-2019-09-05-at-11.50.57-AM-1.png" />
    <meta property="article:published_time" content="2019-09-05T18:57:00.000Z" />
    <meta property="article:modified_time" content="2019-09-05T19:01:41.000Z" />
    <meta property="article:tag" content="WebXR" />
    <meta property="article:tag" content="semantic placement" />
    <meta property="article:tag" content="mozilla" />
    
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="Semantic Placement in Augmented Reality using MrEd" />
    <meta name="twitter:description" content="In this article we’re going to take a brief look at how we may want to think about placement of objects in Augmented Reality.
" />
    <meta name="twitter:url" content="https://blog.mozvr.com/semantic-placement-in-ar/" />
    <meta name="twitter:image" content="https://blog.mozvr.com/content/images/2019/09/Screen-Shot-2019-09-05-at-11.50.57-AM.png" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Anselm Hook" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="WebXR, semantic placement, mozilla" />
    <meta name="twitter:site" content="@mozillareality" />
    <meta name="twitter:creator" content="@anselm" />
    <meta property="og:image:width" content="918" />
    <meta property="og:image:height" content="390" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "Mozilla Mixed Reality Blog",
        "logo": "https://blog.mozvr.com/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png"
    },
    "author": {
        "@type": "Person",
        "name": "Anselm Hook",
        "image": {
            "@type": "ImageObject",
            "url": "https://blog.mozvr.com/content/images/2018/06/anselm.jpg",
            "width": 480,
            "height": 360
        },
        "url": "https://blog.mozvr.com/author/anselm/",
        "sameAs": [
            "http://hook.org",
            "https://twitter.com/anselm"
        ]
    },
    "headline": "Semantic Placement in Augmented Reality using MrEd",
    "url": "https://blog.mozvr.com/semantic-placement-in-ar/",
    "datePublished": "2019-09-05T18:57:00.000Z",
    "dateModified": "2019-09-05T19:01:41.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://blog.mozvr.com/content/images/2019/09/Screen-Shot-2019-09-04-at-12.44.34-PM.png",
        "width": 1686,
        "height": 924
    },
    "keywords": "WebXR, semantic placement, mozilla",
    "description": "In this article we’re going to take a brief look at how we may want to think about placement of objects in Augmented Reality.\n",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://blog.mozvr.com/"
    }
}
    </script>

    <script src="/public/ghost-sdk.min.js?v=e53b21d552"></script>
<script>
ghost.init({
	clientId: "ghost-frontend",
	clientSecret: "e2b06445780a"
});
</script>
    <meta name="generator" content="Ghost 1.26" />
    <link rel="alternate" type="application/rss+xml" title="Mozilla Mixed Reality Blog" href="https://blog.mozvr.com/rss/" />
    <style>
  /* https://blog.mozvr.com/webvr-api-transitions-to-w3c-standard/ */
  .post-card-image[style*="w3c_home"] {
    background-color: #fff;
    background-size: 200px auto;
  }
  .post-full-image[src*="w3c_home"] {
    background-color: #fff;
    height: 18rem;
    object-fit: contain;
  }

  /* https://blog.mozvr.com/firefox-reality-bringing-the-immersive-web-to-mixed-reality-headsets/ */
  .post-card-image[style*="Wordmark"] {
    background-color: #b8cfff;  /* Colour lightened from background colour used in masthead here: https://blog.mozilla.org/blog/2018/04/03/mozilla-brings-firefox-augmented-virtual-reality/ */
    background-size: 90% auto;
  }
  .post-full-image[src*="Wordmark"] {
    height: 14rem;
    object-fit: contain;
  }

  /* https://blog.mozvr.com/bringing-firefox-reality-to-hololens-2/ */
  .post-card-image-link[href*="bringing-firefox-reality-to-hololens-2"] .post-card-image {
    background: #fff url(/content/images/2019/02/F-R-Horizontal-2.png) 50% no-repeat;
    background-size: 80% auto;
  }

  .post-card-excerpt p:after {
    content: "\00a0…";
    opacity: .5;
  }
    
  .post-full-content img,
  .post-full-content video {
    max-width: 840px;
  }

  .post-full-content h2 {
    margin-bottom: .75rem;
  }
</style>
<link async rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.css">

</head>
<body class="post-template tag-webxr tag-semantic-placement tag-mozilla">

    <div class="site-wrapper">

        

<header class="site-header outer">
    <div class="inner">
        <nav class="site-nav">
  <div class="site-nav-left">
    <a href="https://blog.mozvr.com">
      <img class="site-nav__logo" src="/assets/img/mrb-logo.svg?v=e53b21d552" />
    </a>
  </div>
  <div class="site-nav-right">
     <ul class="nav" role="menu">
    <li class="nav-blog" role="menuitem"><a href="https://blog.mozvr.com/">Blog</a></li>
    <li class="nav-mozilla-reality" role="menuitem"><a href="https://mixedreality.mozilla.org">Mozilla Reality</a></li>
    <li class="nav-firefox-reality" role="menuitem"><a href="https://mixedreality.mozilla.org/firefox-reality">Firefox Reality</a></li>
    <li class="nav-aframe" role="menuitem"><a href="https://aframe.io/">A-Frame</a></li>
</ul>
 
  </div>
</nav>
    </div>
</header>


<main id="site-main" class="site-main outer" role="main">
    <div class="inner">

        <article class="post-full post tag-webxr tag-semantic-placement tag-mozilla ">

            <img class="post-full-image" src="/content/images/2019/09/Screen-Shot-2019-09-04-at-12.44.34-PM.png" alt="featured image" />


            <header class="post-full-header">
                    <a href="/tag/webxr/"><span class="post-primary-tag">WebXR</span></a>
                <h1 class="post-full-title">Semantic Placement in Augmented Reality using MrEd</h1>
                <section class="post-full-meta">
                        <img class="post-meta-author-image" src="/content/images/2018/06/anselm.jpg" alt="Anselm Hook" />
                    <span class="post-meta-author"><a href="/author/anselm/">Anselm Hook</a></span>
                    <span>&nbsp;-&nbsp;</span>
                    <time class="post-full-meta-date" datetime="2019-09-05">5 September 2019</time>
                </section>
            </header>
            <section class="post-full-content">
                <div class="kg-card-markdown"><p>In this article we’re going to take a brief look at how we may want to think about placement of objects in Augmented Reality.</p>
<iframe src="https://giphy.com/embed/fxZrMskd67Bhgt30tQ" width="480" height="214" frameBorder="0" class="giphy-embed" allowFullScreen></iframe><p><a href="https://giphy.com/gifs/duck-webxr-fxZrMskd67Bhgt30tQ"></a></p>
<p>Designers often express ideas in a domain appropriate language. For example a designer may say “place that chair on the floor” or “hang that photo at eye level on the wall”.</p>
<p>However when we finalize a virtual scene in 3d we often keep only the literal or absolute XYZ position of elements and throw out the original intent - the deeper reason why an object ended up in a certain position.</p>
<p>It turns out that it’s worth keeping the intention - so that when AR scenes are re-created for new participants or in new physical locations that the scenes still “work” - that they still are satisfying experiences - even if some aspects change.</p>
<p>In a sense this recognizes the Japanese term 'Wabi-Sabi'; that aesthetic placement is always imperfect and contends between fickle forces. Describing placement in terms of semantic intent is also similar to responsive design on the web or the idea of design patterns as described by Christopher Alexander.</p>
<p>Let’s look at two simple examples of semantic placement in practice.</p>
<p><strong>1. Relative to the Ground</strong></p>
<p>When you’re placing objects in augmented reality you often want to specify that those objects should be relationally placed in a position relative to other objects. A typical, in fact ubiquitous, example of placement is that often you want an object to be positioned relative to “the ground”.</p>
<p>Sometimes the designer's intent is to select the highest relative surface underneath the object in question (such as placing a lamp on a table) or at other times to select the lowest relative surface underneath an object (such as say placing a kitten on the floor under a table). Often, as well, we may want to express a placement in the air - such as say a mailbox, or a bird.</p>
<p>In this very small example I’ve attached a ground detection script to a duck, and then sprinkled a few other passive objects around the scene. As the ground is detected the duck will pop down from a default position to be offset relative to the ground (although still in the air). See the GIF above for an example of the effect.</p>
<p>To try this scene out yourself you will need WebXR for iOS which is a preview of emerging WebXR standards and which works with iOS ARKit to expose augmented reality features in a browser environment. This is the url for the scene above in play mode (on a WebXR capable device):</p>
<p><a href="https://painted-traffic.glitch.me/.mred/build/?mode=play&amp;doc=doc_103575453">https://painted-traffic.glitch.me/.mred/build/?mode=play&amp;doc=doc_103575453</a></p>
<p>Here is what it should look like in edit mode:</p>
<p><img src="/content/images/2019/09/Screen-Shot-2019-09-05-at-11.44.10-AM.png" alt="Screen-Shot-2019-09-05-at-11.44.10-AM"></p>
<p>You can also clone the glitch and edit the scene yourself (you’ll want to remember to set a password in the .env file and then login from inside MrEd). See:</p>
<p><a href="https://glitch.com/edit/#!/painted-traffic">https://glitch.com/edit/#!/painted-traffic</a></p>
<p>Here’s my script itself:</p>
<p>/// #title grounded<br>
/// #description Stick to Floor/Ground - dynamically and constantly searching for low areas nearby<br>
({<br>
start: function(evt) {<br>
this.sgp.startWorldInfo()<br>
},<br>
tick: function(e) {<br>
let floor = this.sgp.getFloorNear({point:e.target.position})<br>
if(floor) {<br>
e.target.position.y = floor.y<br>
}<br>
}<br>
})</p>
<p>In the above example I begin by calling startWorldInfo() to start painting the ground planes (so that I can see them since it’s nice to have visual feedback). And, every tick, I call a floor finder subroutine which simply returns the best guess as to the floor in that area. The floor finder logic in this case is baked directly into the editor as a built-in service but one could easily imagine other kinds of floor finding strategies that were more flexible.</p>
<p><strong>2. Follow the player</strong></p>
<p>Another common designer intent is to make sure that some content is always visible to the player. As designers in virtual or augmented reality it can be more challenging to direct a users attention to virtual objects. These are 3d immersive worlds, the player can be looking in any direction. Some kind of mechanic is needed to help make sure that the player sees what they need to see.</p>
<p>One common simple solution is to build an object that stays in front of the user. This can be itself a combination of multiple simpler behaviors. An object can be ordered to seek a position in front of the user, be at a certain height, and ideally billboarded so that any signage or message is always legible.</p>
<p>In this example a sign is decorated with two separate scripts, one to keep the sign in front of the player, and another to billboard the sign to face the player.</p>
<p><a href="https://painted-traffic.glitch.me/.mred/build/?mode=edit&amp;doc=doc_875751741&amp;doctype=vr">https://painted-traffic.glitch.me/.mred/build/?mode=edit&amp;doc=doc_875751741&amp;doctype=vr</a></p>
<iframe src="https://giphy.com/embed/LSFqbRiXjcoJc67bsu" width="480" height="204" frameBorder="0" class="giphy-embed" allowFullScreen></iframe><p><a href="https://giphy.com/gifs/duck-webxr-semantic-LSFqbRiXjcoJc67bsu">via GIPHY</a></p>
<p><strong>Closing thoughts</strong></p>
<p>We’ve only scratched the surface of the kinds of intent could be expressed or combined together. If you want to dive deeper there is a longer list in a separate article <a href="http://https://arvrjourney.com/laundry-list-of-ux-patterns-in-vr-ar-24dae1e56c0a">Laundry List of UX Patterns</a>). I also invite you to help extend the industry; think both about what high level intentions you mean when you place objects and also how you'd communicate those intentions.</p>
<p>The key insight here is that preserving semantic intent means thinking of objects as intelligent, able to respond to simple high level goals. Virtual objects are more than just statues or art at a fixed position, but can be entities that can do your bidding, and follow high level rules.</p>
<p>Ultimately future 3d tools will almost certainly provide these kinds of services - much in the way CSS provides layout directives. We should also expect to see conventions emerge as more designers begin to work in this space. As a call to action, it's worth it to notice the high level intentions that you want, and to get the developers of the tools that you use to start to incorporate those intentions as primitives.</p>
</div>
            </section>

            <section class="subscribe-form">
                <h3 class="subscribe-form-title">Subscribe to Mozilla Mixed Reality Blog</h3>
                <p>Get the latest posts delivered right to your inbox</p>
                <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    
<script>
    (function(g,h,o,s,t){
        var buster = function(b,m) {
            h[o]('input.'+b).forEach(function (i) {
                i.value=i.value || m;
            });
        };
        buster('location', g.location.href);
        buster('referrer', h.referrer);
    })(window,document,'querySelectorAll','value');
</script>

</form>


            </section>

            <footer class="post-full-footer">

                <section class="author-card">
                        <img class="author-profile-image" src="/content/images/2018/06/anselm.jpg" alt="Anselm Hook" />
                    <section class="author-card-content">
                        <h4 class="author-card-name"><a href="/author/anselm/">Anselm Hook</a></h4>
                            <p>Interested in helping people see better. Researching AR/VR for Mozilla.</p>
                    </section>
                </section>
                <div class="post-full-footer-right">
                    <a class="author-card-button" href="/author/anselm/">Read More</a>
                </div>

            </footer>


        </article>

    </div>
</main>

<aside class="read-next outer">
    <div class="inner">
        <div class="read-next-feed">
                <article class="read-next-card"

                >
                    <header class="read-next-card-header">
                        <small class="read-next-card-header-sitetitle">&mdash; Mozilla Mixed Reality Blog &mdash;</small>
                        <h3 class="read-next-card-header-title"><a href="/tag/webxr/">WebXR</a></h3>
                    </header>
                    <div class="read-next-divider"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24"><path d="M13 14.5s2 3 5 3 5.5-2.463 5.5-5.5S21 6.5 18 6.5c-5 0-7 11-12 11C2.962 17.5.5 15.037.5 12S3 6.5 6 6.5s4.5 3.5 4.5 3.5"/></svg>
</div>
                    <div class="read-next-card-content">
                        <ul>
                            <li><a href="/updating-the-webxr-viewer/">Bringing WebXR to iOS</a></li>
                            <li><a href="/bringing-firefox-reality-to-hololens-2/">Bringing Firefox Reality to HoloLens 2</a></li>
                            <li><a href="/updating-the-webxr-viewer-for-ios-12-arkit-2/">Updating the WebXR Viewer for iOS 12 / ARKit 2.0</a></li>
                        </ul>
                    </div>
                    <footer class="read-next-card-footer">
                        <a href="/tag/webxr/">See all 7 posts →</a>
                    </footer>
                </article>


                <article class="post-card post">
        <a class="post-card-image-link" href="/new-avatar-features-in-hubs/">
            <div class="post-card-image" style="background-image: url(/content/images/2019/08/avatar-featured-1.jpg)"></div>
        </a>
    <div class="post-card-content">
        <a class="post-card-content-link" href="/new-avatar-features-in-hubs/">
            <header class="post-card-header">
                <h2 class="post-card-title">New Avatar Features in Hubs</h2>
            </header>
            <section class="post-card-excerpt">
                <p>It is now easier than ever to customize avatars for Hubs! Choosing the way that you represent yourself in a 3D space is an important part of interacting in a virtual world, and</p>
            </section>
        </a>
        <footer class="post-card-meta">
            <span class="post-card-author"><a href="/author/liv/">Liv Erickson</a></span>
        </footer>
    </div>
</article>

        </div>
    </div>
</aside>

<div class="floating-header">
    <div class="floating-header-logo">
        <a href="https://blog.mozvr.com">
            <span>Mozilla Mixed Reality Blog</span>
        </a>
    </div>
    <span class="floating-header-divider">&mdash;</span>
    <div class="floating-header-title">Semantic Placement in Augmented Reality using MrEd</div>
    <div class="floating-header-share">
        <div class="floating-header-share-label">Share this <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24">
    <path d="M7.5 15.5V4a1.5 1.5 0 1 1 3 0v4.5h2a1 1 0 0 1 1 1h2a1 1 0 0 1 1 1H18a1.5 1.5 0 0 1 1.5 1.5v3.099c0 .929-.13 1.854-.385 2.748L17.5 23.5h-9c-1.5-2-5.417-8.673-5.417-8.673a1.2 1.2 0 0 1 1.76-1.605L7.5 15.5zm6-6v2m-3-3.5v3.5m6-1v2"/>
</svg>
</div>
        <a class="floating-header-share-tw" href="https://twitter.com/share?text=Semantic%20Placement%20in%20Augmented%20Reality%20using%20MrEd&amp;url=https://blog.mozvr.com/semantic-placement-in-ar/"
            onclick="window.open(this.href, 'share-twitter', 'width=550,height=235');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M30.063 7.313c-.813 1.125-1.75 2.125-2.875 2.938v.75c0 1.563-.188 3.125-.688 4.625a15.088 15.088 0 0 1-2.063 4.438c-.875 1.438-2 2.688-3.25 3.813a15.015 15.015 0 0 1-4.625 2.563c-1.813.688-3.75 1-5.75 1-3.25 0-6.188-.875-8.875-2.625.438.063.875.125 1.375.125 2.688 0 5.063-.875 7.188-2.5-1.25 0-2.375-.375-3.375-1.125s-1.688-1.688-2.063-2.875c.438.063.813.125 1.125.125.5 0 1-.063 1.5-.25-1.313-.25-2.438-.938-3.313-1.938a5.673 5.673 0 0 1-1.313-3.688v-.063c.813.438 1.688.688 2.625.688a5.228 5.228 0 0 1-1.875-2c-.5-.875-.688-1.813-.688-2.75 0-1.063.25-2.063.75-2.938 1.438 1.75 3.188 3.188 5.25 4.25s4.313 1.688 6.688 1.813a5.579 5.579 0 0 1 1.5-5.438c1.125-1.125 2.5-1.688 4.125-1.688s3.063.625 4.188 1.813a11.48 11.48 0 0 0 3.688-1.375c-.438 1.375-1.313 2.438-2.563 3.188 1.125-.125 2.188-.438 3.313-.875z"/></svg>
        </a>
        <a class="floating-header-share-fb" href="https://www.facebook.com/sharer/sharer.php?u=https://blog.mozvr.com/semantic-placement-in-ar/"
            onclick="window.open(this.href, 'share-facebook','width=580,height=296');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M19 6h5V0h-5c-3.86 0-7 3.14-7 7v3H8v6h4v16h6V16h5l1-6h-6V7c0-.542.458-1 1-1z"/></svg>
        </a>
    </div>
    <progress class="progress" value="0">
        <div class="progress-container">
            <span class="progress-bar"></span>
        </div>
    </progress>
</div>




         <footer class="footer">
  <div class="footer__inner">

    <div>
      <a href="http://mozilla.org">
        <img class="footer__logo" src="/assets/img/moz-logo.svg?v=e53b21d552" />
      </a>
    </div>
    <div>
      <span class="footer__title">Additional Links</span>
      <ul class="footer__list">
        <li>
          <a href="https://vr.mozilla.org">Mozilla Mixed Reality</a>
        </li>
        <li>
          <a href="https://aframe.io/">A-Frame</a>
        </li>
        <li>
          <a href="https://aframe.io/blog/">A-Frame Blog</a>
        </li>
        <li>
          <a href="https://twitter.com/mozillareality">Twitter</a>
        </li>
        <li>
          <a href="https://github.com/mozillareality">GitHub</a>
        </li>
      </ul>
    </div>
    <div>
      <span class="footer__title">Mozilla</span>
      <ul class="footer__list">
        <li>
          <a href="https://www.mozilla.org/about/">About</a>
        </li>
        <li>
          <a href="https://www.mozilla.org/contact/">Contact Us</a>
        </li>
        <li>
          <a href="https://donate.mozilla.org/en-US/?presets=100,50,25,15&amp;amount=50&amp;utm_source=mozilla.org&amp;utm_medium=referral&amp;utm_content=footer&amp;currency=usd">Donate</a>
        </li>
      </ul>
    </div>
  </div>
  <div class="footer__legal">
    <ul class="footer__legal-list">
      <li>
        <a href="https://www.mozilla.org/privacy/">Privacy</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/privacy/websites/#cookies">Cookies</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/about/legal/">Legal</a>
      </li>
    </ul>
  </div>
</footer>

    </div>

    <div id="subscribe" class="subscribe-overlay">
        <a class="subscribe-overlay-close" href="#"></a>
        <div class="subscribe-overlay-content">
                <img class="subscribe-overlay-logo" src="/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" alt="Mozilla Mixed Reality Blog" />
            <h1 class="subscribe-overlay-title">Subscribe to Mozilla Mixed Reality Blog</h1>
            <p class="subscribe-overlay-description">Stay up to date! Get all the latest &amp; greatest posts delivered straight to your inbox</p>
            <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    
<script>
    (function(g,h,o,s,t){
        var buster = function(b,m) {
            h[o]('input.'+b).forEach(function (i) {
                i.value=i.value || m;
            });
        };
        buster('location', g.location.href);
        buster('referrer', h.referrer);
    })(window,document,'querySelectorAll','value');
</script>

</form>


        </div>
    </div>

    <script
        src="https://code.jquery.com/jquery-3.2.1.min.js"
        integrity="sha256-hwg4gsxgFZhOsEEamdOYGBf13FyQuiTwlAQgxVSNgt4="
        crossorigin="anonymous">
    </script>
    <script type="text/javascript" src="/assets/js/jquery.fitvids.js?v=e53b21d552"></script>


    <script>

// NOTE: Scroll performance is poor in Safari
// - this appears to be due to the events firing much more slowly in Safari.
//   Dropping the scroll event and using only a raf loop results in smoother
//   scrolling but continuous processing even when not scrolling
$(document).ready(function () {
    // Start fitVids
    var $postContent = $(".post-full-content");
    $postContent.fitVids();
    // End fitVids

    var progressBar = document.querySelector('progress');
    var header = document.querySelector('.floating-header');
    var title = document.querySelector('.post-full-title');

    var lastScrollY = window.scrollY;
    var lastWindowHeight = window.innerHeight;
    var lastDocumentHeight = $(document).height();
    var ticking = false;

    function onScroll() {
        lastScrollY = window.scrollY;
        requestTick();
    }

    function onResize() {
        lastWindowHeight = window.innerHeight;
        lastDocumentHeight = $(document).height();
        requestTick();
    }

    function requestTick() {
        if (!ticking) {
            requestAnimationFrame(update);
        }
        ticking = true;
    }

    function update() {
        var trigger = title.getBoundingClientRect().top + window.scrollY;
        var triggerOffset = title.offsetHeight + 35;
        var progressMax = lastDocumentHeight - lastWindowHeight;

        // show/hide floating header
        if (lastScrollY >= trigger + triggerOffset) {
            header.classList.add('floating-active');
        } else {
            header.classList.remove('floating-active');
        }

        progressBar.setAttribute('max', progressMax);
        progressBar.setAttribute('value', lastScrollY);

        ticking = false;
    }

    window.addEventListener('scroll', onScroll, {passive: true});
    window.addEventListener('resize', onResize, false);

    update();
});
</script>


    <script src="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.js"></script>
<script>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</script>

</body>
</html>
