<!DOCTYPE html>
<html>
<head>

    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />

    <title>Custom elements for the immersive web</title>
    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="stylesheet" type="text/css" href="/assets/built/screen.css?v=d2a214724c" />

    <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
    <link rel="canonical" href="https://blog.mozvr.com/custom-elements-for-the-immersive-web/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    
    <meta property="og:site_name" content="Mozilla Mixed Reality Blog" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Custom elements for the immersive web" />
    <meta property="og:description" content="We are happy to introduce the first set of custom elements for the immersive web we have been working on: &amp;lt;img-360&amp;gt; and &amp;lt;video-360&amp;gt; From the Mixed Reality team, we keep working on improving the content creator experience, building new frameworks, tools, APIs, performance tuning and so" />
    <meta property="og:url" content="https://blog.mozvr.com/custom-elements-for-the-immersive-web/" />
    <meta property="og:image" content="https://blog.mozvr.com/content/images/2019/08/img360-1.png" />
    <meta property="article:published_time" content="2019-08-12T19:28:22.000Z" />
    <meta property="article:modified_time" content="2019-08-12T20:06:37.000Z" />
    <meta property="article:tag" content="custom elements" />
    <meta property="article:tag" content="img-360" />
    <meta property="article:tag" content="video-360" />
    
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="Custom elements for the immersive web" />
    <meta name="twitter:description" content="We are happy to introduce the first set of custom elements for the immersive web we have been working on: &amp;lt;img-360&amp;gt; and &amp;lt;video-360&amp;gt; From the Mixed Reality team, we keep working on improving the content creator experience, building new frameworks, tools, APIs, performance tuning and so" />
    <meta name="twitter:url" content="https://blog.mozvr.com/custom-elements-for-the-immersive-web/" />
    <meta name="twitter:image" content="https://blog.mozvr.com/content/images/2019/08/img360-1.png" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Fernando Serrano" />
    <meta name="twitter:label2" content="Filed under" />
    <meta name="twitter:data2" content="custom elements, img-360, video-360" />
    <meta name="twitter:site" content="@mozillareality" />
    <meta name="twitter:creator" content="@fernandojsg" />
    <meta property="og:image:width" content="2574" />
    <meta property="og:image:height" content="1284" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "Mozilla Mixed Reality Blog",
        "logo": "https://blog.mozvr.com/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png"
    },
    "author": {
        "@type": "Person",
        "name": "Fernando Serrano",
        "image": {
            "@type": "ImageObject",
            "url": "https://blog.mozvr.com/content/images/2016/09/98d3708e-47ec-11e6-817c-4d5fdfba80a9.jpg",
            "width": 400,
            "height": 400
        },
        "url": "https://blog.mozvr.com/author/fernando/",
        "sameAs": [
            "http://fernandojsg.com",
            "https://twitter.com/fernandojsg"
        ]
    },
    "headline": "Custom elements for the immersive web",
    "url": "https://blog.mozvr.com/custom-elements-for-the-immersive-web/",
    "datePublished": "2019-08-12T19:28:22.000Z",
    "dateModified": "2019-08-12T20:06:37.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://blog.mozvr.com/content/images/2019/08/img360-1.png",
        "width": 2574,
        "height": 1284
    },
    "keywords": "custom elements, img-360, video-360",
    "description": "We are happy to introduce the first set of custom elements for the immersive web we have been working on: &amp;lt;img-360&amp;gt; and &amp;lt;video-360&amp;gt; From the Mixed Reality team, we keep working on improving the content creator experience, building new frameworks, tools, APIs, performance tuning and so",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://blog.mozvr.com/"
    }
}
    </script>

    <script src="/public/ghost-sdk.min.js?v=d2a214724c"></script>
<script>
ghost.init({
	clientId: "ghost-frontend",
	clientSecret: "e2b06445780a"
});
</script>
    <meta name="generator" content="Ghost 1.26" />
    <link rel="alternate" type="application/rss+xml" title="Mozilla Mixed Reality Blog" href="https://blog.mozvr.com/rss/" />
    <style>
  /* https://blog.mozvr.com/webvr-api-transitions-to-w3c-standard/ */
  .post-card-image[style*="w3c_home"] {
    background-color: #fff;
    background-size: 200px auto;
  }
  .post-full-image[src*="w3c_home"] {
    background-color: #fff;
    height: 18rem;
    object-fit: contain;
  }

  /* https://blog.mozvr.com/firefox-reality-bringing-the-immersive-web-to-mixed-reality-headsets/ */
  .post-card-image[style*="Wordmark"] {
    background-color: #b8cfff;  /* Colour lightened from background colour used in masthead here: https://blog.mozilla.org/blog/2018/04/03/mozilla-brings-firefox-augmented-virtual-reality/ */
    background-size: 90% auto;
  }
  .post-full-image[src*="Wordmark"] {
    height: 14rem;
    object-fit: contain;
  }

  /* https://blog.mozvr.com/bringing-firefox-reality-to-hololens-2/ */
  .post-card-image-link[href*="bringing-firefox-reality-to-hololens-2"] .post-card-image {
    background: #fff url(/content/images/2019/02/F-R-Horizontal-2.png) 50% no-repeat;
    background-size: 80% auto;
  }

  .post-card-excerpt p:after {
    content: "\00a0…";
    opacity: .5;
  }
    
  .post-full-content img,
  .post-full-content video {
    max-width: 840px;
  }

  .post-full-content h2 {
    margin-bottom: .75rem;
  }
</style>
<link async rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.css">

</head>
<body class="post-template tag-custom-elements tag-img-360 tag-video-360">

    <div class="site-wrapper">

        

<header class="site-header outer">
    <div class="inner">
        <nav class="site-nav">
  <div class="site-nav-left">
    <a href="https://blog.mozvr.com">
      <img class="site-nav__logo" src="/assets/img/mrb-logo.svg?v=d2a214724c" />
    </a>
  </div>
  <div class="site-nav-right">
     <ul class="nav" role="menu">
    <li class="nav-blog" role="menuitem"><a href="https://blog.mozvr.com/">Blog</a></li>
    <li class="nav-mozilla-reality" role="menuitem"><a href="https://mixedreality.mozilla.org">Mozilla Reality</a></li>
    <li class="nav-firefox-reality" role="menuitem"><a href="https://mixedreality.mozilla.org/firefox-reality">Firefox Reality</a></li>
    <li class="nav-aframe" role="menuitem"><a href="https://aframe.io/">A-Frame</a></li>
</ul>
 
  </div>
</nav>
    </div>
</header>


<main id="site-main" class="site-main outer" role="main">
    <div class="inner">

        <article class="post-full post tag-custom-elements tag-img-360 tag-video-360 ">

            <img class="post-full-image" src="/content/images/2019/08/img360-1.png" alt="featured image" />


            <header class="post-full-header">
                    <a href="/tag/custom-elements/"><span class="post-primary-tag">custom elements</span></a>
                <h1 class="post-full-title">Custom elements for the immersive web</h1>
                <section class="post-full-meta">
                        <img class="post-meta-author-image" src="/content/images/2016/09/98d3708e-47ec-11e6-817c-4d5fdfba80a9.jpg" alt="Fernando Serrano" />
                    <span class="post-meta-author"><a href="/author/fernando/">Fernando Serrano</a></span>
                    <span>&nbsp;-&nbsp;</span>
                    <time class="post-full-meta-date" datetime="2019-08-12">12 August 2019</time>
                </section>
            </header>
            <section class="post-full-content">
                <div class="kg-card-markdown"><p>We are happy to introduce the first set of custom elements for the immersive web we have been working on: <code>&lt;img-360&gt;</code> and <code>&lt;video-360&gt;</code></p>
<p>From the Mixed Reality team, we keep working on improving the content creator experience, building new frameworks, tools, APIs, performance tuning and so on.<br>
Most of these projects are based on the assumption that the users have a basic knowledge of 3D graphics and want to go deep on fully customizing their WebXR experience, (eg: using <a href="https://aframe.io">A-Frame</a> or <a href="https://threejs.org">three.js</a>).<br>
But there are still a lot of use cases where content creators just want very simple interactions and don’t have the knowledge or time to create and maintain a custom application built on top of a WebXR framework.</p>
<p>With this project we aim to address the problems these content creators have by providing custom elements with simple, yet polished features. One could be just a simple 360 image or video viewer, another one could be a tour allowing the user to jump from one image to another.</p>
<p><img src="/content/images/2019/08/img-360-animation.gif" alt="img-360-animation"></p>
<p><a href="https://developer.mozilla.org/en-US/docs/Web/Web_Components/Using_custom_elements">Custom elements</a> provide a standard way to create HTML elements to provide simple functionality that matches expectations of content creators without knowledge of 3D, WebXR or even Javascript.</p>
<h2 id="howdoesthiswork">How does this work?</h2>
<p>Just include the Javascript bundle on your page and you could start using both elements in your HTML: <code>&lt;img-360&gt;</code> and <code>&lt;video-360&gt;</code>. You just need to provide them with a 360 image or video and the custom elements will do the rest, including detecting WebVR support. Here is a simple example that adds a 360 image and video to a page. All of the interaction controls are generated automatically:</p>
<style>
    .gist {width: 100%}
</style>
<script src="https://gist.github.com/fernandojsg/263b87009825dee4177696e9817505b0.js"></script>
<p>You can try a demo <a href="https://mixedreality.mozilla.org/immersive-custom-elements/examples/index.html">here</a> and find detailed information on how to use them <a href="https://github.com/MozillaReality/immersive-custom-elements#custom-element-tags">on Github</a>.</p>
<h2 id="nextsteps">Next steps</h2>
<p>Today we are releasing just these two elements but we have many others in mind and would love your feedback. What new elements would you find useful? Please <a href="https://github.com/MozillaReality/immersive-custom-elements">join us on GitHub</a> to discuss them.<br>
We are also excited to see other companies working hard on providing quality custom elements for the 3D and XR web as Google with their <a href="https://github.com/GoogleWebComponents/model-viewer"><code>&lt;model-viewer&gt;</code> component</a> and we hope others will follow.</p>
</div>
            </section>

            <section class="subscribe-form">
                <h3 class="subscribe-form-title">Subscribe to Mozilla Mixed Reality Blog</h3>
                <p>Get the latest posts delivered right to your inbox</p>
                <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    
<script>
    (function(g,h,o,s,t){
        var buster = function(b,m) {
            h[o]('input.'+b).forEach(function (i) {
                i.value=i.value || m;
            });
        };
        buster('location', g.location.href);
        buster('referrer', h.referrer);
    })(window,document,'querySelectorAll','value');
</script>

</form>


            </section>

            <footer class="post-full-footer">

                <section class="author-card">
                        <img class="author-profile-image" src="/content/images/2016/09/98d3708e-47ec-11e6-817c-4d5fdfba80a9.jpg" alt="Fernando Serrano" />
                    <section class="author-card-content">
                        <h4 class="author-card-name"><a href="/author/fernando/">Fernando Serrano</a></h4>
                            <p>Read <a href="/author/fernando/">more posts</a> by this author.</p>
                    </section>
                </section>
                <div class="post-full-footer-right">
                    <a class="author-card-button" href="/author/fernando/">Read More</a>
                </div>

            </footer>


        </article>

    </div>
</main>

<aside class="read-next outer">
    <div class="inner">
        <div class="read-next-feed">


                <article class="post-card post">
        <a class="post-card-image-link" href="/a-summer-with-particles-and-emojis/">
            <div class="post-card-image" style="background-image: url(/content/images/2019/08/Asset_69.png)"></div>
        </a>
    <div class="post-card-content">
        <a class="post-card-content-link" href="/a-summer-with-particles-and-emojis/">
            <header class="post-card-header">
                <h2 class="post-card-title">A Summer with Particles and Emojis</h2>
            </header>
            <section class="post-card-excerpt">
                <p>This summer I am very lucky to join the Hubs by Mozilla as a technical artist intern. Over the 12 weeks that I was at Mozilla, I worked on two different projects. My</p>
            </section>
        </a>
        <footer class="post-card-meta">
            <span class="post-card-author"><a href="/author/siyu/">Siyu Chen</a></span>
        </footer>
    </div>
</article>

        </div>
    </div>
</aside>

<div class="floating-header">
    <div class="floating-header-logo">
        <a href="https://blog.mozvr.com">
            <span>Mozilla Mixed Reality Blog</span>
        </a>
    </div>
    <span class="floating-header-divider">&mdash;</span>
    <div class="floating-header-title">Custom elements for the immersive web</div>
    <div class="floating-header-share">
        <div class="floating-header-share-label">Share this <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24">
    <path d="M7.5 15.5V4a1.5 1.5 0 1 1 3 0v4.5h2a1 1 0 0 1 1 1h2a1 1 0 0 1 1 1H18a1.5 1.5 0 0 1 1.5 1.5v3.099c0 .929-.13 1.854-.385 2.748L17.5 23.5h-9c-1.5-2-5.417-8.673-5.417-8.673a1.2 1.2 0 0 1 1.76-1.605L7.5 15.5zm6-6v2m-3-3.5v3.5m6-1v2"/>
</svg>
</div>
        <a class="floating-header-share-tw" href="https://twitter.com/share?text=Custom%20elements%20for%20the%20immersive%20web&amp;url=https://blog.mozvr.com/custom-elements-for-the-immersive-web/"
            onclick="window.open(this.href, 'share-twitter', 'width=550,height=235');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M30.063 7.313c-.813 1.125-1.75 2.125-2.875 2.938v.75c0 1.563-.188 3.125-.688 4.625a15.088 15.088 0 0 1-2.063 4.438c-.875 1.438-2 2.688-3.25 3.813a15.015 15.015 0 0 1-4.625 2.563c-1.813.688-3.75 1-5.75 1-3.25 0-6.188-.875-8.875-2.625.438.063.875.125 1.375.125 2.688 0 5.063-.875 7.188-2.5-1.25 0-2.375-.375-3.375-1.125s-1.688-1.688-2.063-2.875c.438.063.813.125 1.125.125.5 0 1-.063 1.5-.25-1.313-.25-2.438-.938-3.313-1.938a5.673 5.673 0 0 1-1.313-3.688v-.063c.813.438 1.688.688 2.625.688a5.228 5.228 0 0 1-1.875-2c-.5-.875-.688-1.813-.688-2.75 0-1.063.25-2.063.75-2.938 1.438 1.75 3.188 3.188 5.25 4.25s4.313 1.688 6.688 1.813a5.579 5.579 0 0 1 1.5-5.438c1.125-1.125 2.5-1.688 4.125-1.688s3.063.625 4.188 1.813a11.48 11.48 0 0 0 3.688-1.375c-.438 1.375-1.313 2.438-2.563 3.188 1.125-.125 2.188-.438 3.313-.875z"/></svg>
        </a>
        <a class="floating-header-share-fb" href="https://www.facebook.com/sharer/sharer.php?u=https://blog.mozvr.com/custom-elements-for-the-immersive-web/"
            onclick="window.open(this.href, 'share-facebook','width=580,height=296');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M19 6h5V0h-5c-3.86 0-7 3.14-7 7v3H8v6h4v16h6V16h5l1-6h-6V7c0-.542.458-1 1-1z"/></svg>
        </a>
    </div>
    <progress class="progress" value="0">
        <div class="progress-container">
            <span class="progress-bar"></span>
        </div>
    </progress>
</div>




         <footer class="footer">
  <div class="footer__inner">

    <div>
      <a href="http://mozilla.org">
        <img class="footer__logo" src="/assets/img/moz-logo.svg?v=d2a214724c" />
      </a>
    </div>
    <div>
      <span class="footer__title">Additional Links</span>
      <ul class="footer__list">
        <li>
          <a href="https://vr.mozilla.org">Mozilla Mixed Reality</a>
        </li>
        <li>
          <a href="https://aframe.io/">A-Frame</a>
        </li>
        <li>
          <a href="https://aframe.io/blog/">A-Frame Blog</a>
        </li>
        <li>
          <a href="https://twitter.com/mozillareality">Twitter</a>
        </li>
        <li>
          <a href="https://github.com/mozillareality">GitHub</a>
        </li>
      </ul>
    </div>
    <div>
      <span class="footer__title">Mozilla</span>
      <ul class="footer__list">
        <li>
          <a href="https://www.mozilla.org/about/">About</a>
        </li>
        <li>
          <a href="https://www.mozilla.org/contact/">Contact Us</a>
        </li>
        <li>
          <a href="https://donate.mozilla.org/en-US/?presets=100,50,25,15&amp;amount=50&amp;utm_source=mozilla.org&amp;utm_medium=referral&amp;utm_content=footer&amp;currency=usd">Donate</a>
        </li>
      </ul>
    </div>
  </div>
  <div class="footer__legal">
    <ul class="footer__legal-list">
      <li>
        <a href="https://www.mozilla.org/privacy/">Privacy</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/privacy/websites/#cookies">Cookies</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/about/legal/">Legal</a>
      </li>
    </ul>
  </div>
</footer>

    </div>

    <div id="subscribe" class="subscribe-overlay">
        <a class="subscribe-overlay-close" href="#"></a>
        <div class="subscribe-overlay-content">
                <img class="subscribe-overlay-logo" src="/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" alt="Mozilla Mixed Reality Blog" />
            <h1 class="subscribe-overlay-title">Subscribe to Mozilla Mixed Reality Blog</h1>
            <p class="subscribe-overlay-description">Stay up to date! Get all the latest &amp; greatest posts delivered straight to your inbox</p>
            <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    
<script>
    (function(g,h,o,s,t){
        var buster = function(b,m) {
            h[o]('input.'+b).forEach(function (i) {
                i.value=i.value || m;
            });
        };
        buster('location', g.location.href);
        buster('referrer', h.referrer);
    })(window,document,'querySelectorAll','value');
</script>

</form>


        </div>
    </div>

    <script
        src="https://code.jquery.com/jquery-3.2.1.min.js"
        integrity="sha256-hwg4gsxgFZhOsEEamdOYGBf13FyQuiTwlAQgxVSNgt4="
        crossorigin="anonymous">
    </script>
    <script type="text/javascript" src="/assets/js/jquery.fitvids.js?v=d2a214724c"></script>


    <script>

// NOTE: Scroll performance is poor in Safari
// - this appears to be due to the events firing much more slowly in Safari.
//   Dropping the scroll event and using only a raf loop results in smoother
//   scrolling but continuous processing even when not scrolling
$(document).ready(function () {
    // Start fitVids
    var $postContent = $(".post-full-content");
    $postContent.fitVids();
    // End fitVids

    var progressBar = document.querySelector('progress');
    var header = document.querySelector('.floating-header');
    var title = document.querySelector('.post-full-title');

    var lastScrollY = window.scrollY;
    var lastWindowHeight = window.innerHeight;
    var lastDocumentHeight = $(document).height();
    var ticking = false;

    function onScroll() {
        lastScrollY = window.scrollY;
        requestTick();
    }

    function onResize() {
        lastWindowHeight = window.innerHeight;
        lastDocumentHeight = $(document).height();
        requestTick();
    }

    function requestTick() {
        if (!ticking) {
            requestAnimationFrame(update);
        }
        ticking = true;
    }

    function update() {
        var trigger = title.getBoundingClientRect().top + window.scrollY;
        var triggerOffset = title.offsetHeight + 35;
        var progressMax = lastDocumentHeight - lastWindowHeight;

        // show/hide floating header
        if (lastScrollY >= trigger + triggerOffset) {
            header.classList.add('floating-active');
        } else {
            header.classList.remove('floating-active');
        }

        progressBar.setAttribute('max', progressMax);
        progressBar.setAttribute('value', lastScrollY);

        ticking = false;
    }

    window.addEventListener('scroll', onScroll, {passive: true});
    window.addEventListener('resize', onResize, false);

    update();
});
</script>


    <script src="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.js"></script>
<script>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</script>

</body>
</html>
