<!DOCTYPE html>
<html>
<head>

    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=edge" />

    <title>Close Conversation is the Future of Social VR</title>
    <meta name="HandheldFriendly" content="True" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />

    <link rel="stylesheet" type="text/css" href="/assets/built/screen.css?v=f7d92082b9" />

    <link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />
    <link rel="canonical" href="https://blog.mozvr.com/close-conversation-is-the-future-of-social-vr/" />
    <meta name="referrer" content="no-referrer-when-downgrade" />
    
    <meta property="og:site_name" content="Mozilla Mixed Reality Blog" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Close Conversation is the Future of Social VR" />
    <meta property="og:description" content="In many user experience (UX) studies, the researchers give the participants a task and then observe what happens next. Most research participants are earnest and usually attempt to follow instructions.  However, in this study, research participants mostly ignored instructions and just started goofing off with each other once they entered" />
    <meta property="og:url" content="https://blog.mozvr.com/close-conversation-is-the-future-of-social-vr/" />
    <meta property="og:image" content="https://blog.mozvr.com/content/images/2018/10/Physical-comedy-works---2.jpg" />
    <meta property="article:published_time" content="2018-10-06T02:01:24.000Z" />
    <meta property="article:modified_time" content="2018-10-06T02:04:41.000Z" />
    <meta name="twitter:card" content="summary_large_image" />
    <meta name="twitter:title" content="Close Conversation is the Future of Social VR" />
    <meta name="twitter:description" content="In many user experience (UX) studies, the researchers give the participants a task and then observe what happens next. Most research participants are earnest and usually attempt to follow instructions.  However, in this study, research participants mostly ignored instructions and just started goofing off with each other once they entered" />
    <meta name="twitter:url" content="https://blog.mozvr.com/close-conversation-is-the-future-of-social-vr/" />
    <meta name="twitter:image" content="https://blog.mozvr.com/content/images/2018/10/Physical-comedy-works---3.jpg" />
    <meta name="twitter:label1" content="Written by" />
    <meta name="twitter:data1" content="Jessica Outlaw" />
    <meta name="twitter:site" content="@mozillareality" />
    <meta property="og:image:width" content="1287" />
    <meta property="og:image:height" content="711" />
    
    <script type="application/ld+json">
{
    "@context": "https://schema.org",
    "@type": "Article",
    "publisher": {
        "@type": "Organization",
        "name": "Mozilla Mixed Reality Blog",
        "logo": "https://blog.mozvr.com/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png"
    },
    "author": {
        "@type": "Person",
        "name": "Jessica Outlaw",
        "url": "https://blog.mozvr.com/author/jessica/",
        "sameAs": []
    },
    "headline": "Close Conversation is the Future of Social VR",
    "url": "https://blog.mozvr.com/close-conversation-is-the-future-of-social-vr/",
    "datePublished": "2018-10-06T02:01:24.000Z",
    "dateModified": "2018-10-06T02:04:41.000Z",
    "image": {
        "@type": "ImageObject",
        "url": "https://blog.mozvr.com/content/images/2018/10/Physical-comedy-works--.jpg",
        "width": 1287,
        "height": 711
    },
    "description": "In many user experience (UX) studies, the researchers give the participants a task and then observe what happens next. Most research participants are earnest and usually attempt to follow instructions.  However, in this study, research participants mostly ignored instructions and just started goofing off with each other once they entered",
    "mainEntityOfPage": {
        "@type": "WebPage",
        "@id": "https://blog.mozvr.com/"
    }
}
    </script>

    <script src="/public/ghost-sdk.min.js?v=f7d92082b9"></script>
<script>
ghost.init({
	clientId: "ghost-frontend",
	clientSecret: "e2b06445780a"
});
</script>
    <meta name="generator" content="Ghost 1.25" />
    <link rel="alternate" type="application/rss+xml" title="Mozilla Mixed Reality Blog" href="https://blog.mozvr.com/rss/" />
    <style>
  /* https://blog.mozvr.com/webvr-api-transitions-to-w3c-standard/ */
  .post-card-image[style*="w3c_home"] {
    background-color: #fff;
    background-size: 200px auto;
  }
  .post-full-image[src*="w3c_home"] {
    background-color: #fff;
    height: 18rem;
    object-fit: contain;
  }

  /* https://blog.mozvr.com/firefox-reality-bringing-the-immersive-web-to-mixed-reality-headsets/ */
  .post-card-image[style*="Wordmark"] {
    background-color: #b8cfff;  /* Colour lightened from background colour used in masthead here: https://blog.mozilla.org/blog/2018/04/03/mozilla-brings-firefox-augmented-virtual-reality/ */
    background-size: 90% auto;
  }
  .post-full-image[src*="Wordmark"] {
    height: 14rem;
    object-fit: contain;
  }

  .post-card-excerpt p:after {
    content: "\00a0…";
    opacity: .5;
  }
    
  .post-full-content img,
  .post-full-content video {
    max-width: 840px;
  }

  .post-full-content h2 {
    margin-bottom: .75rem;
  }
</style>
<link async rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.css">

</head>
<body class="post-template">

    <div class="site-wrapper">

        

<header class="site-header outer">
    <div class="inner">
        <nav class="site-nav">
  <div class="site-nav-left">
    <a href="https://blog.mozvr.com">
      <img class="site-nav__logo" src="/assets/img/mrb-logo.svg?v=f7d92082b9" />
    </a>
  </div>
  <div class="site-nav-right">
     <ul class="nav" role="menu">
    <li class="nav-blog" role="menuitem"><a href="https://blog.mozvr.com/">Blog</a></li>
    <li class="nav-mozilla-reality" role="menuitem"><a href="https://mixedreality.mozilla.org">Mozilla Reality</a></li>
    <li class="nav-firefox-reality" role="menuitem"><a href="https://mixedreality.mozilla.org/firefox-reality">Firefox Reality</a></li>
    <li class="nav-aframe" role="menuitem"><a href="https://aframe.io/">A-Frame</a></li>
</ul>
 
  </div>
</nav>
    </div>
</header>


<main id="site-main" class="site-main outer" role="main">
    <div class="inner">

        <article class="post-full post ">

            <img class="post-full-image" src="/content/images/2018/10/Physical-comedy-works--.jpg" alt="featured image" />


            <header class="post-full-header">
                <h1 class="post-full-title">Close Conversation is the Future of Social VR</h1>
                <section class="post-full-meta">
                    <span class="post-meta-author"><a href="/author/jessica/">Jessica Outlaw</a></span>
                    <span>&nbsp;-&nbsp;</span>
                    <time class="post-full-meta-date" datetime="2018-10-06">6 October 2018</time>
                </section>
            </header>
            <section class="post-full-content">
                <div class="kg-card-markdown"><p>In many user experience (UX) studies, the researchers give the participants a task and then observe what happens next. Most research participants are earnest and usually attempt to follow instructions.  However, in this study, research participants mostly ignored instructions and just started goofing off with each other once they entered the immersive space and testing the limits of embodiment.</p>
<p>The goal of this blog post is to share insights from Hubs by Mozilla usability study that other XR creators could apply to building a multi-user space.</p>
<p>The Extended Mind recruited pairs of people who communicate online with each other every day, which led to testing Hubs with people who have very close connections. There were three romantic partners in the study, one pair of roommates, and one set of high school BFFs. The reason that The Extended Mind recruited relatively intimate pairs of people is because they wanted to understand the potential for Hubs as a communication platform for people who already have good relationships.  They also believe that they got more insights about how people would use Hubs in a natural environment rather than bringing in one person at a time and asking that person to hang out in VR with a stranger who they just met.</p>
<p>The two key insights that this blog post will cover are the ease of conversation that people had in Hubs and the playfulness that they embodied when using it.</p>
<p><strong>Conversation Felt Natural</strong></p>
<p>When people enter Hubs, the first thing they would do would be to look around to find the other person in the space.  Regardless of if they were on mobile, laptop, tablet or in a VR headset, their primary goal was to connect.  Once they located the other person, they immediately gave their impressions of the other person’s avatar and asked what they looked like to their companion.  There was an element of fun in finding the other person and then discussing avatar appearances.  Including one romantic partner sincerely telling his companion:</p>
<blockquote>
<p>“You are adorable,”</p>
</blockquote>
<p>…which indicates that his warm feelings for her in the real world easily translated to her avatar.</p>
<p>The researchers created conversational prompts for all of the research participants such as “Plan a potential vacation together,” but participants ignored the instructions and just talked about whatever caught their attention.  Mostly people were self-directed in exploring their capabilities in the environment and wanted to communicate with their companion. They relished having visual cues from the other person and experiencing embodiment:</p>
<p>“Having a hand to move around felt more connected. Especially when we both had hands.”</p>
<blockquote>
<p>“It felt like we were next to each other.”</p>
</blockquote>
<p>The youngest participants in the study were in their early twenties and stated that they avoided making phone calls. They rated Hubs more highly than a phone conversation due to the improved sense of connection it gave them.</p>
<blockquote>
<p>[Hubs is] “better than a phone call.”</p>
</blockquote>
<p>Some even considered it superior to texting for self-expression:</p>
<blockquote>
<p>“Texting doesn’t capture our full [expression]”</p>
</blockquote>
<p>The data from this study shows that communication using 2D devices and VR headsets has strong potential for personal conversation among friends and partners. People appeared to feel strong connections with their partners in the space. They wanted to revisit the space in the future with groups of close friends and share it with them as well.</p>
<p><strong>Participants Had Fun</strong></p>
<p>Due to participants feeling comfortable in the space and confident in their ability to express themselves, they relaxed during the testing session and let their sense of humor show through.</p>
<p>The researchers observed a lot of joke-telling and goofiness from people.  A consequence of feeling embodied in the VR headset was acting in ways to entertain their companion:</p>
<blockquote>
<p>“Physical humor works here.”</p>
</blockquote>
<p>Users also discovered that Hubs has a rubber duck mascot that will quack when it is clicked and it will replicate itself.  Playing with the duck was very popular.</p>
<blockquote>
<p>“The duck makes a delightful sound.”</p>
<p>“Having things to play with is good.”</p>
</blockquote>
<p>Here's one image to illustrate the rubber ducks multiplying quickly:<br>
<img src="/content/images/2018/10/Hubs-by-Mozilla-Rubber-Ducks.png" alt="Hubs-by-Mozilla-Rubber-Ducks"></p>
<p>It could be a future research question to determine exactly what is the balance of giving people something like the duck as a fidget activity versus a formal board game or card game. The lack of formality in Hubs appeared to actually bolster the storytelling aspects that users brought to it. Two users established a whole rubber duck Law &amp; Order type tv show where they gave the ducks roles:</p>
<blockquote>
<p>“Good cop duckie, bad cop duckie.”</p>
</blockquote>
<p>People either forgot or ignored the researchers’ instructions to plan a vacation or other prompts because they were immersed in the fun and connection together.  However, the watching the users tell each other stories and experiment in the space was more entertaining and led to more insights.</p>
<p>While it wasn’t actually tested in this study, there are ways to add media &amp; gifs to Hubs to further enhance communication and comedy.</p>
<p><strong>Summary: A Private Space That Let People Be Themselves</strong></p>
<p>The Extended Mind believes that the privacy of the Hubs space bolstered people’s intimate experiences. Because people must have a unique URL to gain access, it limited the number of people in the room. That gave people a sense of control and likely led the them feeling comfortable experimenting with the layers of embodiment and having fun with each other.</p>
<p>The next blog post will cover additional insights about how the different environments in Hubs impacted their behavior and what other XR creators can apply to their own work.</p>
<blockquote>
<blockquote>
<blockquote>
<blockquote></blockquote>
</blockquote>
</blockquote>
</blockquote>
<p>This article is part two of the series that reviews the user testing conducted on Mozilla’s social XR platform, Hubs. Mozilla partnered with Jessica Outlaw and Tyesha Snow of <a href="http://www.extendedmind.io">The Extended Mind</a> to validate that Hubs was accessible, safe, and scalable. The goal of the research was to generate insights about the user experience and deliver recommendations of how to improve the Hubs product.</p>
<p>To read part one of the blog series overview, which focused on accessibility, <a href="https://blog.mozvr.com/mozilla-hubs-immersive-communication-on-any-device/">click here.  </a></p>
</div>
            </section>

            <section class="subscribe-form">
                <h3 class="subscribe-form-title">Subscribe to Mozilla Mixed Reality Blog</h3>
                <p>Get the latest posts delivered right to your inbox</p>
                <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    
<script>
    (function(g,h,o,s,t){
        var buster = function(b,m) {
            h[o]('input.'+b).forEach(function (i) {
                i.value=i.value || m;
            });
        };
        buster('location', g.location.href);
        buster('referrer', h.referrer);
    })(window,document,'querySelectorAll','value');
</script>

</form>


            </section>

            <footer class="post-full-footer">

                <section class="author-card">
                    <section class="author-card-content">
                        <h4 class="author-card-name"><a href="/author/jessica/">Jessica Outlaw</a></h4>
                            <p>Read <a href="/author/jessica/">more posts</a> by this author.</p>
                    </section>
                </section>
                <div class="post-full-footer-right">
                    <a class="author-card-button" href="/author/jessica/">Read More</a>
                </div>

            </footer>


        </article>

    </div>
</main>

<aside class="read-next outer">
    <div class="inner">
        <div class="read-next-feed">


                <article class="post-card post">
        <a class="post-card-image-link" href="/drawing-and-photos-now-in-hubs/">
            <div class="post-card-image" style="background-image: url(/content/images/2018/10/output.gif)"></div>
        </a>
    <div class="post-card-content">
        <a class="post-card-content-link" href="/drawing-and-photos-now-in-hubs/">
            <header class="post-card-header">
                <h2 class="post-card-title">Drawing and Photos, now in Hubs</h2>
            </header>
            <section class="post-card-excerpt">
                <p>Two new features that will further enrich the ways you can connect and collaborate in rooms you create in Hubs: drawing and easy photo uploads.</p>
            </section>
        </a>
        <footer class="post-card-meta">
                <img class="author-profile-image" src="/content/images/2018/10/asset.JPG" alt="Kevin Lee" />
            <span class="post-card-author"><a href="/author/kevin/">Kevin Lee</a></span>
        </footer>
    </div>
</article>

        </div>
    </div>
</aside>

<div class="floating-header">
    <div class="floating-header-logo">
        <a href="https://blog.mozvr.com">
            <span>Mozilla Mixed Reality Blog</span>
        </a>
    </div>
    <span class="floating-header-divider">&mdash;</span>
    <div class="floating-header-title">Close Conversation is the Future of Social VR</div>
    <div class="floating-header-share">
        <div class="floating-header-share-label">Share this <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 24 24">
    <path d="M7.5 15.5V4a1.5 1.5 0 1 1 3 0v4.5h2a1 1 0 0 1 1 1h2a1 1 0 0 1 1 1H18a1.5 1.5 0 0 1 1.5 1.5v3.099c0 .929-.13 1.854-.385 2.748L17.5 23.5h-9c-1.5-2-5.417-8.673-5.417-8.673a1.2 1.2 0 0 1 1.76-1.605L7.5 15.5zm6-6v2m-3-3.5v3.5m6-1v2"/>
</svg>
</div>
        <a class="floating-header-share-tw" href="https://twitter.com/share?text=Close%20Conversation%20is%20the%20Future%20of%20Social%20VR&amp;url=https://blog.mozvr.com/close-conversation-is-the-future-of-social-vr/"
            onclick="window.open(this.href, 'share-twitter', 'width=550,height=235');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M30.063 7.313c-.813 1.125-1.75 2.125-2.875 2.938v.75c0 1.563-.188 3.125-.688 4.625a15.088 15.088 0 0 1-2.063 4.438c-.875 1.438-2 2.688-3.25 3.813a15.015 15.015 0 0 1-4.625 2.563c-1.813.688-3.75 1-5.75 1-3.25 0-6.188-.875-8.875-2.625.438.063.875.125 1.375.125 2.688 0 5.063-.875 7.188-2.5-1.25 0-2.375-.375-3.375-1.125s-1.688-1.688-2.063-2.875c.438.063.813.125 1.125.125.5 0 1-.063 1.5-.25-1.313-.25-2.438-.938-3.313-1.938a5.673 5.673 0 0 1-1.313-3.688v-.063c.813.438 1.688.688 2.625.688a5.228 5.228 0 0 1-1.875-2c-.5-.875-.688-1.813-.688-2.75 0-1.063.25-2.063.75-2.938 1.438 1.75 3.188 3.188 5.25 4.25s4.313 1.688 6.688 1.813a5.579 5.579 0 0 1 1.5-5.438c1.125-1.125 2.5-1.688 4.125-1.688s3.063.625 4.188 1.813a11.48 11.48 0 0 0 3.688-1.375c-.438 1.375-1.313 2.438-2.563 3.188 1.125-.125 2.188-.438 3.313-.875z"/></svg>
        </a>
        <a class="floating-header-share-fb" href="https://www.facebook.com/sharer/sharer.php?u=https://blog.mozvr.com/close-conversation-is-the-future-of-social-vr/"
            onclick="window.open(this.href, 'share-facebook','width=580,height=296');return false;">
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 32 32"><path d="M19 6h5V0h-5c-3.86 0-7 3.14-7 7v3H8v6h4v16h6V16h5l1-6h-6V7c0-.542.458-1 1-1z"/></svg>
        </a>
    </div>
    <progress class="progress" value="0">
        <div class="progress-container">
            <span class="progress-bar"></span>
        </div>
    </progress>
</div>




         <footer class="footer">
  <div class="footer__inner">

    <div>
      <a href="http://mozilla.org">
        <img class="footer__logo" src="/assets/img/moz-logo.svg?v=f7d92082b9" />
      </a>
    </div>
    <div>
      <span class="footer__title">Additional Links</span>
      <ul class="footer__list">
        <li>
          <a href="https://vr.mozilla.org">Mozilla Mixed Reality</a>
        </li>
        <li>
          <a href="https://aframe.io/">A-Frame</a>
        </li>
        <li>
          <a href="https://aframe.io/blog/">A-Frame Blog</a>
        </li>
        <li>
          <a href="https://twitter.com/mozillareality">Twitter</a>
        </li>
        <li>
          <a href="https://github.com/mozillareality">GitHub</a>
        </li>
      </ul>
    </div>
    <div>
      <span class="footer__title">Mozilla</span>
      <ul class="footer__list">
        <li>
          <a href="https://www.mozilla.org/about/">About</a>
        </li>
        <li>
          <a href="https://www.mozilla.org/contact/">Contact Us</a>
        </li>
        <li>
          <a href="https://donate.mozilla.org/en-US/?presets=100,50,25,15&amp;amount=50&amp;utm_source=mozilla.org&amp;utm_medium=referral&amp;utm_content=footer&amp;currency=usd">Donate</a>
        </li>
      </ul>
    </div>
  </div>
  <div class="footer__legal">
    <ul class="footer__legal-list">
      <li>
        <a href="https://www.mozilla.org/privacy/">Privacy</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/privacy/websites/#cookies">Cookies</a>
      </li>
      <li>
        <a href="https://www.mozilla.org/about/legal/">Legal</a>
      </li>
    </ul>
  </div>
</footer>

    </div>

    <div id="subscribe" class="subscribe-overlay">
        <a class="subscribe-overlay-close" href="#"></a>
        <div class="subscribe-overlay-content">
                <img class="subscribe-overlay-logo" src="/content/images/2017/12/2017.05.09.mozilla.hacks_.3-dino-halftone-09-1400x770.png" alt="Mozilla Mixed Reality Blog" />
            <h1 class="subscribe-overlay-title">Subscribe to Mozilla Mixed Reality Blog</h1>
            <p class="subscribe-overlay-description">Stay up to date! Get all the latest &amp; greatest posts delivered straight to your inbox</p>
            <form method="post" action="/subscribe/" class="">
    <input class="confirm" type="hidden" name="confirm"  /><input class="location" type="hidden" name="location"  /><input class="referrer" type="hidden" name="referrer"  />

    <div class="form-group">
        <input class="subscribe-email" type="email" name="email"  placeholder="youremail@example.com" />
    </div>
    <button class="" type="submit"><span>Subscribe</span></button>
    
<script>
    (function(g,h,o,s,t){
        var buster = function(b,m) {
            h[o]('input.'+b).forEach(function (i) {
                i.value=i.value || m;
            });
        };
        buster('location', g.location.href);
        buster('referrer', h.referrer);
    })(window,document,'querySelectorAll','value');
</script>

</form>


        </div>
    </div>

    <script
        src="https://code.jquery.com/jquery-3.2.1.min.js"
        integrity="sha256-hwg4gsxgFZhOsEEamdOYGBf13FyQuiTwlAQgxVSNgt4="
        crossorigin="anonymous">
    </script>
    <script type="text/javascript" src="/assets/js/jquery.fitvids.js?v=f7d92082b9"></script>


    <script>

// NOTE: Scroll performance is poor in Safari
// - this appears to be due to the events firing much more slowly in Safari.
//   Dropping the scroll event and using only a raf loop results in smoother
//   scrolling but continuous processing even when not scrolling
$(document).ready(function () {
    // Start fitVids
    var $postContent = $(".post-full-content");
    $postContent.fitVids();
    // End fitVids

    var progressBar = document.querySelector('progress');
    var header = document.querySelector('.floating-header');
    var title = document.querySelector('.post-full-title');

    var lastScrollY = window.scrollY;
    var lastWindowHeight = window.innerHeight;
    var lastDocumentHeight = $(document).height();
    var ticking = false;

    function onScroll() {
        lastScrollY = window.scrollY;
        requestTick();
    }

    function onResize() {
        lastWindowHeight = window.innerHeight;
        lastDocumentHeight = $(document).height();
        requestTick();
    }

    function requestTick() {
        if (!ticking) {
            requestAnimationFrame(update);
        }
        ticking = true;
    }

    function update() {
        var trigger = title.getBoundingClientRect().top + window.scrollY;
        var triggerOffset = title.offsetHeight + 35;
        var progressMax = lastDocumentHeight - lastWindowHeight;

        // show/hide floating header
        if (lastScrollY >= trigger + triggerOffset) {
            header.classList.add('floating-active');
        } else {
            header.classList.remove('floating-active');
        }

        progressBar.setAttribute('max', progressMax);
        progressBar.setAttribute('value', lastScrollY);

        ticking = false;
    }

    window.addEventListener('scroll', onScroll, {passive: true});
    window.addEventListener('resize', onResize, false);

    update();
});
</script>


    <script src="https://cdnjs.cloudflare.com/ajax/libs/prism/0.0.1/prism.min.js"></script>
<script>
(function () {
  /* global ga, performance */
  // Toggle this variable to output to the console debug GA messages.
  var debug = false;
  function initGoogleAnalytics (id, opts) {
    (function (c, v, a, n) {
      c.GoogleAnalyticsObject = n;

      c[n] = c[n] || function () {
        (c[n].q = c[n].q || []).push(arguments);
      };
      c[n].l = 1 * new Date();

      var s = v.createElement('script');
      s.async = true;
      s.src = a;
      s.addEventListener('load', enableDebug);

      var m = v.getElementsByTagName('script')[0];
      m.parentNode.insertBefore(s, m);
    })(window, document, 'https://www.google-analytics.com/analytics.js', 'ga');

    function enableDebug () {
      if (!debug) {
        return;
      }
      window.ga = ga = console.info.bind(console);
    }

    enableDebug();

    ga('create', id, opts);
    ga('set', 'forceSSL', true);
    ga('send', 'pageview');
  }

  function initGoogleAnalyticsEvents () {
    window.addEventListener('load', function () {
      setTimeout(function () {
        var t = performance.timing;
        // Credit to https://github.com/addyosmani/timing.js/blob/c58c164/timing.js#L67-L88:
        // Total time from start to load.
        gaSendPageTiming('loadTime', t.loadEventEnd - t.fetchStart);
        // Time spent constructing the DOM tree.
        gaSendPageTiming('domReadyTime', t.domComplete - t.domInteractive);
        // Time consumed preparing the new page.
        gaSendPageTiming('readyStart', t.fetchStart - t.navigationStart);
        // Time spent during redirection.
        gaSendPageTiming('redirectTime', t.redirectEnd - t.redirectStart);
        // AppCache.
        gaSendPageTiming('appcacheTime', t.domainLookupStart - t.fetchStart);
        // Time spent unloading documents.
        gaSendPageTiming('unloadEventTime', t.unloadEventEnd - t.unloadEventStart);
        // DNS query time.
        gaSendPageTiming('lookupDomainTime', t.domainLookupEnd - t.domainLookupStart);
        // TCP connection time.
        gaSendPageTiming('connectTime', t.connectEnd - t.connectStart);
        // Time spent during the request.
        gaSendPageTiming('requestTime', t.responseEnd - t.requestStart);
        // Request to completion of the DOM loading.
        gaSendPageTiming('initDomTreeTime', t.domInteractive - t.responseEnd);
        // Load event time.
        gaSendPageTiming('loadEventTime', t.loadEventEnd - t.loadEventStart);
      });
    });

    var gaSendTiming = function (timingCategory, timingLabel) {
      return function (timingVar, timeEnd) {
        if (typeof timeEnd === 'undefined') {
          timeEnd = performance.now();
        }
        ga('send', {
          hitType: 'timing',
          timingCategory: timingCategory,
          timingVar: timingVar,
          timingValue: timeEnd,
          timingLabel: timingLabel
        });
      };
    };

    var gaSendPageTiming = gaSendTiming('page');

    ga('send', 'event', 'pageload.title', document.title);
    ga('send', 'event', 'pageload.location', window.location.href);
    ga('send', 'event', 'pageload.pathname', window.location.pathname);
    ga('send', 'event', 'pageload.querystring', window.location.search);
    ga('send', 'event', 'pageload.hash', window.location.hash);

    // NOTE: These lines are commented out because Steam VR / Oculus would open on desktop.
    //ga('send', 'event', 'supports.getVRDisplays', 'getVRDisplays' in navigator);
    //ga('send', 'event', 'supports.getVRDevices', 'getVRDevices' in navigator);

    function handleOutboundLinkClicks (evt) {
      ga('send', 'event', {
        eventCategory: 'Outbound Link',
        eventAction: 'click',
        eventLabel: evt.target.href,
        transport: 'beacon'
      });
    }

    window.addEventListener('click', function (evt) {
      var el = evt.target.closest && evt.target.closest('a[href], input[type=button], button, img, picture');
      if (!el) { return; }
      //var txt = getElText(el);
      //if (!txt) { return; }
      handleOutboundLinkClicks(evt);
    });
  }

  function getElText (el) {
    var txt = el.textContent.trim();
    if (txt) {
      return txt;
    }
    var img = el.tagName === 'IMG' ? el : el.querySelector('img');
    if (img) {
      return img.getAttribute('alt') || img.getAttribute('title');
    }
    return '';
  }
  initGoogleAnalytics('UA-77033033-11', {alwaysSendReferrer: true});
  initGoogleAnalyticsEvents();
})();
</script>

</body>
</html>
